How to Enable and Disable Kami as Default File Viewer?

When you open a file on your browser, you can enable and disable Kami as the default viewer. Here’s how:

  1. Click your profile icon found on the upper right corner of the window.
  2. Then, click Settings.

Tick ‘Automatically Load Files in Kami’ if you want Kami as your default file viewer. While untick the option if you don’t want Kami to be the default viewer.

Click Update to save, then Go Back to go back to the main Kami app.

Google Drive Steps

If you have Kami installed in Google Drive, follow these steps:

Go to drive.google.com, then Settings —> Manage Apps —> Uncheck “Use by Default”

You can fully disconnect Kami by following these steps:

Go to drive.google.com, then Settings —> Manage Apps —> Options —> Disconnect Kami from Drive.

There is not an option in the profile for ‘Automatically Load Files in Kami’. There is only ‘Automatically Save My Changes to Google Drive’ and ‘Enable Browser Notifications’. How can I get this malware/ransomware off my chromebook so I can view .doc files again?

Just like @walksonwater19, there is not an option for unticking “Automatically Load Files in Kami”. It even acts as the default for .docx files. There must be a way to disable this feature.

This is EXTREMELY frustrating. It used to be possible to disable automatically open in Kami. You must have made some change recently, because now it always opens automatically. I go to settings and auto open is NOT checked. I even tried checking and unchecking. No good Great product but please fix this. One wants Kami for certain purposes but not necessarily for opening every file.

This is SO frustrating! I cannot find a way to STOP Kami from opening every single time I open a file! This is incredibly frustrating. I am a teacher and I do not want to use Kami for EVERYTHING. Please advise.

Hello sbowcut, walksonwater19, esontag, and moehrlein!

I am very sorry for the late reply.

We were not clear in the instructions, and I am sorry for the frustration this has caused.

The ‘Automatically Load Files in Kami’ option is only available in the Kami extension. Please go to the Kami extension and follow the same steps previously mentioned, and you will see this option.

Here is the Google Chrome extension: https://chrome.google.com/webstore/detail/kami-pdf-and-document-mar/ecnphlgnajanjnkcmbpancdjoidceilk?hl=en

Hope this helps!

So you are telling me that I have to download your extension to get rid of an issue that you caused? I find this to be a GREAT excuse to scam people into downloading your extension despite not wanting to use it.

Edit: I would also like to mention that it is YOUR responsibility to make sure this issue does not occur. And moreover the solution should not be downloading more of your products when trying to remove it in the first place.

We have uninstall instructions here: http://support.kamihq.com/knowledge_base/topics/how-do-i-uninstall . If you have our Chrome app installed on your chromebook, you can uninstall that by right clicking on Kami in the app launcher and choosing ‘Remove from chrome’.

We certainly have no intention of forcing you to use any of our products if you don’t find them useful.

Thanks
Jordan

I keep having the exact same problem: Chrome opens all the pdf files automatically on Kami, even though Automatically Load Files in Kami is UNchecked (I do have the app) and the Chrome PDF Viewer plugin is allowed.
How can I fix this? As another commenter said, I love Kami, but I want to use it when I need it, not all the time.
Thanks,

Cristina

Cristina,

Could you please email us with a screencast of the problem? We’d like to get engineering to look into it deeper. The reason why we haven’t been able to fix it is because we haven’t seen it on our development machines.

Please email us at support@kamihq.com mentioning this post.

I have the another problem. Even though I set Automatically Load Files in Kami, the file doesn’t open in Kami. It opens in default viewer in chrome. I reinstalled many times. Doesn’t work.

Anybody? I really need it. Help pls. I even reinstalled Google Chrome. I set Automatically Load files in Kami and the file still opens in default pdf viewer. Change it many times. Reinstalled Kami may times. Nothing works. What’s the solution?

I’ve tried this, unchecked the box, but it’s still defaulting to Kami. I’ve even checked settings on my browser to make sure. It was working for a while, but has since defaulted to Kami despite everything I’ve tried. Sorry, but something is going on here that isn’t user-error.

I am also noticing weird Chrome behaviour in the way it is managing PDF. I have set Kami not to load PDF files automatically, since I don’t want it to be doing so while I may only be in the need to preview a PDF email attachment, for example. This seems to stick for a bit and Chrome uses the default native PDF Viewer, but after a while, when I click a PDF I notice the behaviour in Chrome is different and then it starts downloading the PDF files and opening the files with my OS PDF viewer (for example Preview on macOS).

Something is not Ok with Kami and Chrome. I really need this solver asap. Thanks,

So, nobody can help me? Do you even care?

Hi mrozikpl!

I apologize for the late reply.

We are still trying to figure out the exact cause of this. We have never been able to replicate the issue on our side, and we do not see any user error messages, so it is very difficult to see what the issue is.

It would help us greatly if you, or anyone experiencing this issue, had time to speak with us via Skype or Google Hangouts. That way, we could see what is happening from your side.

If you have time, please email hello@kamihq.com so we can schedule a time.

Thank you for the reply!

Kami is very important for my job because whenever I open my files, Kami save my last read point. I have a large collection of pdfs.

I reinstalled Kami, Google chrome, also tried different version of chrome. Tried beta version of chrome. Nothing works, It just stopped some day.
Tried also install on different account of google chrome. Still nothing.
Right now I used Google Chrome 56.0.2924.59 beta (64-bit)
And the latest Kami.
I will try also on different computer.
I’m going to be a premium user, so please try to find out what happend.

OK, I figure it out.

If I want to open pdf file from my PC I first start Kami in Chrome (just click the extension, chrome running)
Then files open automatically in Kami. Hope this info helps to resolve the problem.

Thank you for your patience.

I believe we have found the cause of the issue. For Chromebook users, this issue occurs when downloads are set to go to Google Drive, and then the settings within Drive are set to automatically open within Kami. Here is how to fix this.

First, navigate to the Files app.

  1. Click the App Launcher icon in the bottom-left corner of your screen.
  2. Locate the app icon for Files and click it.

Once in the Files app:

  1. Select the type of file that is being automatically opened (ppt, docx, etc)
  2. Click Open -> Change default to whichever option is best for you

Please let us know this does not work for you!

Marshall,
Is it possible to do the above on a desktop computer?
Thanks!
Pete