How to Enable and Disable Kami as Default File Viewer?

I have been having a problem where I am unable to open any link with the ‘Open link with Kami’ option when you right click a pdf link - it just opens in google’s pdf viewer as normal. The extension works as it should when ‘Automatically Load Files in Kami is ticked’ but I would like to choose which links open in Kami, not have to turn it on or off every time. Is this possible?

Hi BW95!

Thank you for the feedback. This is a known issue that we are working to fix.

I apologize for the inconvenience.

Even though I removed Kami from Chrome OS I still get the option in the Open by default selection, how can I completely get rid of Kami?

Hi Danny,

Did you try this yet?:

First, navigate to the Files app.

  1. Click the App Launcher icon in the bottom-left corner of your screen.
  2. Locate the app icon for Files and click it.

Once in the Files app:

  1. Select the type of file that is being automatically opened (ppt, docx, etc)
  2. Click Open -> Change default to whichever option is best for you

Yes I saw that in the topic but why does the Kami option still exist even though Kami is removed? I can alter all the preferences but it shouldn’t be needed after removing the extension.

Hi Danny,

This is a ChromeOS bug. We are still waiting on Google to fix it.

Kami should not be set as the default opener for any non-PDF file type, but Drive sets Kami as a default opener.

I apologize for the inconvenience.

I’m also experiencing this difficulty. Incredibly frustrating, and preventing me from productive work. Very disappointed in this app.

Hi Lynn,

I apologize for the issues you are having.

There is nothing we can do to fix this, because it is an error on Google’s side. However, you may want to check Google Drive.

I would suggest following these directions, as you may have Kami installed in Drive:

Go to, then Settings --> Manage Apps --> Uncheck “Use by Default”

You can also disconnect Kami from Drive by following these steps:

Settings --> Manage Apps --> Options --> Disconnect Kami from Drive.

Thanks for your reply - much appreciated. This did in fact work - grateful. Sure hope google fixes this for you soon.