Thumbnails Not Appearing in Split and Merge

I’m having difficulties with the photo thumbnails loading when I click on split and merge and try to add documents/PDFs from Google Drive. The thumbnails are visible when you don’t split and merge and you just open from Google Drive. It doesn’t seem to be happening on others’ accounts at my school. I have tried uninstalling/reinstalling the kami app, clearing all browsing history, cookies and caches, resetting Google Chrome, updating my computer, and restarting the computer. Any other ideas would be helpful.

Did you try waiting for the thumbnails to work? If that doesn’t work, try using a different network, or if you can’t use a different network, try restarting your network.
Hope this helps!

Yes, I have tried waiting for the thumbnails to load, but they don’t. I have tried using a different network too. Thanks for the suggestions!

Have you tried looking it up on to see if there a way to fix your promblem… It may help
I dont have much to say I never had this happen to me before and I had kami and google drive to 7 years.