Annotations Showing Automatically

I’m a teacher. I often push out copies PDF to my students through Google Classroom, and ask students to annotate them using Kami. Before I upgraded to the teacher plan, my students always had to download a copy of their annotated PDF to their own Google Drive and then share with me (by attaching it to the Google Classroom assignment). Once I upgraded to the teacher plan, I was able to see my students’ annotations on their PDF’s without them having to take the extra step of downloading and attaching their annotated copy. However, this isn’t happening will ALL students. Is there a setting that the students need to change?

Hi MrsConroy3,

If you select the option Make a copy for each student, then your students can open the file directly into Kami from Google Classroom.

When the students open the copy, their annotations will be saved back to Drive, as long as they are making sure to save their annotations within Kami. They save their annotations by selecting the Save button, which looks like a floppy disk, and then navigating to Save now under the Google Drive heading.

Without all of the information, it sounds to me like some of your students are not saving their changes back to Drive before turning in the assignment. You will still see them in Kami (the Kami cloud save is separate from the Drive save), but you will not see them in Drive.

If you have any more questions, please email

Hope this helps!

Sometimes I think the issue is students are trying to access documents from private gmail account and not their school account. This can happen if they accept an invitation when using their personal account. It is really important kids are using the account u invited them with.