"Open with Kami" PDF overlay button does not work

After opening a PDF in Chrome, the “Open with Kami” button appears in the upper right corner, but clicking on it has no effect. How do I fix this?

I’m running Chrome 69 and have installed the extension. I have Kami Pro, and I’m returning to it after several years.

PDFs automatically open in Kami when I turn on the “Open in Kami by default” option, so that works. But, in my case, I’d prefer not to open every PDF in Kami by default.

Testing notes:

  • Evernote extension has a PDF overlay button that works fine.
  • Disabling the Evernote extension doesn’t seem to fix the Kami problem.
  • I test-installed the DocHub extension, which also has a PDF overlay button, and it had the same issue as Kami.
  • I tested on both Windows 10 and my Chromebook.

Any advice?

Kami was a good tool when I started using it, and is even better now–keep up the excellent work!

P.S. Your blog is down. :frowning: